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Service Management CD - Mandatory Fields and Configuration Guide

In This Article

Introduction

To ensure your team captures all necessary details for each repair, you can configure the Overview and Segment Headers to require specific information before a Ticket moves through the pipeline. The following list identifies every available field by category and specifies which ones you can set as mandatory to maintain data integrity.

Overview

Field Name

Can be Mandatory

Configuration Key

Status

Always Mandatory

n/a

Promise Date

Yes

SVL.Ticket.PromiseDate.Required

Branch

Always Mandatory

n/a

Cost Center

No

 

Job Control

Yes

SVL.Ticket.JobControl.FreeForm.Mandatory

Customer

Some of these fields will be populated by your ERP and are mandatory when you create a Work Order. If you are missing any required information, an error message from your ERP will be displayed identifying what is missing.

Field Name

Can be Mandatory

Configuration Key

Customer

Always Mandatory

n/a

Address

No

 

City/State

No

 

ZIP

No

 

Phone

No

 

PO No

No

 

Terms

No

 

Tax Codes

No

 

Exempt No

No

 

Charge Code

Yes

SVL.Ticket.Header.ChargeCode1.Required / SVL.Ticket.Header.ChargeCode2.Required

Equipment

Some of these fields will be populated by your ERP and are mandatory when you create a Work Order. If you are missing any required information, an error message from your ERP will be displayed identifying what is missing.

Field Name

Can be Mandatory

Configuration Key

Serial Number

Always Mandatory

n/a

Manufacturer

Always Mandatory

n/a

Model

No

 

Year

Yes

SVL.Ticket.YearOfManuf.Required

Unit No

No

 

Stock No

No

 

Division

Always Mandatory

n/a

Product Type

No

 

Ind Class

Yes

SVL.Ticket.IndustCode.Mandatory.Enabled

Delivery Date

No

 

SMU

No

 

SMU type

No

 

SMU Date

No

 

Cab Type

No

 

Arr No

No

 

VIN

No

 

Job Site - Field

Field Name

Can be Mandatory

Configuration Key

Job Site

No

 

Description

No

 

Address

No

 

County

No

 

City/State

No

 

ZIP

No

 

Phone

No

 

Est. Arrival

Yes

SVL.Field.EstArrival.Required

Arrival Date

No

 

Shop Instructions - Shop

Field Name

Can be Mandatory

Configuration Key

Source

No

 

Est Unit Arrival

Yes

SVL.Shop.EstArrival.Required

Arrival Date

No

 

Instruction

No

 

Estimate

Configuration Key - SVL.Estimate.Mandatory - requires at least one of the Parts, Labor, Misc, or Estimated All fields to be populated.

Field Name

Can be Mandatory

Configuration Key

Parts

No

 

Labor

No

 

Misc

No

 

Estimated All

No

 

Estimated By

No

 

Related

Some of these fields will be populated by your ERP and are mandatory when you create a Work Order. If you are missing any required information, an error message from your ERP will be displayed identifying what is missing.

Field Name

Can be Mandatory

Configuration Key / Note

Serial No

No

 

Manufacturer

No

Will be mandatory if a Serial Number is entered.

Model

No

 

Arr No

No

 

Other

Field Name

Can be Mandatory

Configuration Key

Bus Group

No

 

Charge Level

No

 

End User Code

No

 

OT Auth

No

 

Sales Rep

No

 

Labor Inv Ind

No

 

Job Priority

No

 

Diff Owner

No

 

Customer Commitment

This section is visible or hidden by Configuration Key - Temp.SVL.ServiceExcellence.CustomerCommitment.Fields.

Field Name

Can be Mandatory

Configuration Key

Initial Request

Yes

SVL.InitialRequestDate.Mandatory

Requested Start

No

 

Commitment Response

No

 

Requested Completion

No

 

Contact

Field Name

Can be Mandatory

Configuration Key

Name

Always Mandatory

n/a

Home Phone Number

Yes

SVL.Contact.Phone.Required

Mobile Phone Number

No

 

Email

No

 

Frequency

Yes

SVL.Contact.Frequency.NotRequired

Frequency By

No

Will be mandatory if a frequency is entered.

Symptom

Field Name

Can be Mandatory

Configuration Key

Component

Yes

SVL.Ticket.Symptom.ComponentId.IsMandatory

Major Symptom

Yes

SVL.Ticket.Symptom.MajorSymptom.IsMandatory

Minor Symptom

Yes

SVL.Ticket.Symptom.MinorSymptom.IsMandatory

Codes or Alarms

No

 

Complaint

Always Mandatory

n/a

Cause

No

 

Damage

No

 

Complication

No

 

Date

No

 

When

No

 

Correction

No

 

Segment Header

Field Name

Can be Mandatory

Configuration Key

Segment No

Always Mandatory

n/a

Job Code

Always Mandatory

n/a

Component Code

Always Mandatory

n/a

Modifier

No

 

Shop Field

Always Mandatory

n/a

Business Group

No

 

Qty Code

No

 

Store No

Always Mandatory

n/a

Cost Center

Always Mandatory

n/a

Qty

No

 

Std Hours

Yes

SVL.Segment.StdHours.Required

Job Location

No

 

Work App

No

 

Division

Always Mandatory

n/a

Marketing Program

No

 

F/R Exchange

No

 

PIP/PSP No

No

 

SIMS Req

No

 

Display Operations on Invoice

No

 

Resp Mechanic

No

 

Comb F/R on Inv

No